InSpec Classic or InSpec Freezes

Description of the Symptoms and Issues

InSpec Classic

  • InSpec Classic freezes during operation when the zoom magnification is changed or during playback.

  • Zoom move failed error/timeout messages given in the Error.trl:

    PH2Zoom.cpp(916): Zoom wait_settle failed during initialization PH2Zoom.cpp(1594): Zoom move from 7.7037 to 22.6974: error = -14.9938
  • Can be resolved by restarting InSpec Classic and the machine.

  • InSpec Classic optics calibration disappears during operation, i.e. no magnification numbers are displayed

    • This is distinct from the optics calibration disappearing after an initialization warning, which is typically associated with an aging or failing zoom lens.

  • The P2-ZB firmware version is less than 4.2.0 in MotorScope.

InSpec

  • InSpec freezes during operation when the optical magnification is changed.

  • InSpec splash screen does not disappear on connection to a machine.

  • Can be resolved by restarting InSpec and the machine.

  • The P2-ZB firmware version is less than 4.2.0 in Machine > Machine Information.

Check Zoom PCB Firmware Version

The firmware version is listed in Motorscope as shown below:

grafik-20241205-153033.png

 

Cause

This issue is most likely caused by an exceptional state of the motor controller that is related to the combination of the motor, motor encoder, and specific lens. Swapping the motor or the lens would typically fix this problem before the introduction of the firmware update.

Solution

Using InSpec Classic

  1. Using InSpec Classic, go to the Machine Menu and select Upgrade firmware. Browse for the attached firmware package.

  2. Click Update and wait for the firmware upgrade to complete. Do not allow a power loss to occur during the upgrade process or the zoom board may be irreparably damaged.

  3. When the firmware update is complete, close InSpec Classic and power off the machine.

  4. Power up the machine, open InSpec Classic, and Initialize the machine.

Using InSpec

  1. Using InSpec, check the InSpec version by looking at the “Version:” in the “Help” drop-down menu.

  2. If the InSpec version is below (RC) 1.8.0
    select “Check for Updates..” in the same menu and perform the update to the most recent InSpec version using the in-program updater.

  3. Power-cycle the machine, open InSpec, and Initialize the machine.

 

 

Product information is subject to change without prior notice as a result of ongoing technical development